2007 S550 4matic rear end dropped

ChannelZer0 • 29 July 2019
0 comments
0 likes

It is my first Mercedes and its been treating me well.  I ran into my first issue with it a couple of weeks ago.  I drove into work in the morning and had no issues, normal drive. I drove home for lunch and on my way down my driveway, the rear sounded and felt stiff.

I got out and saw both sides of the rear were lowered to the top of the rear tires behind the wheel wells. Low rider!  The front was fine. I hooked up SDS and ran the quick test to see if it would throw a code.  It did not.  I also did not have the front dash warning about not driving because the car was too low.  Next, I ran the pneumatic tests.

w221 rear dropped

The pump and front level control valves passed, the rears both failed for the level control valves. I ran all the other tests, and they all passed, including pump and leak tests.  Playing around some more I noticed you can manually go into each strut and add or bleed air to them.

To my surprise, I was able to pump the rear up. I re-ran the tests and the rear passed this time, with a slight exception I only realized later on.

When it first runs the pneumatic tests, it attempts to level each air strut if needed.  Even when pumped up, the rear tests would just stop at the test for a second and move on.  The fronts would take its time and feel it out.

I left it for 30 minutes, and it held its position.  Then I drove up the driveway and back down, a 30-second drive at best. When I returned to the garage, the rear was almost back to the floor again. 

What the heck?  I hooked up SDS again and pumped up the rear.  I left it overnight and it didnt move.  Up the driveway and again the rear end sank down.  I was puzzled.  I did some reading and everyone was pointing to the air struts. 

It was "just one of the things you will have to do with airmatic suspension, they blow out."  A local indy was looking at $1800-2000 to replace both rear struts and was convinced it was likely the issue.  I am not one to give in though and persisted. 

I was puzzled about both rear struts going out at the the same time and the ability to pump up the rear and then pass the tests via SDS.  It went down once I started driving but I never heard a leak then or when conducting tests.  I got a schematic of the airmatic system and started testing additional components. 

I moved the car up and down the driveway again, checking the back wheels every 5-10 seconds. They were moving down. When I got back down the driveway, they were nearly all the way down again. I hooked up SDS and found no trouble codes in the airmatic system.

I then ran all the pneumatic tests and the left and right rear failed.  It said, "Component 'Y36/6y3 and /6y4(left and right rear level control valves)' is not operating correctly or the line between the valve block and the suspension strut is not leaking tight."  I ran the following tests and it passed them all. The airmatic pressure release valve, leakage test between valve block and central reservoir and leakage between the compressor and valve block.

There didn't seem to be a leak anywhere to me.  I dug a little deeper in SDS and found some additional testing for the airmatic components. When I tested the rear level sensor, it was severely under voltage, at 0.45V instead of the range of 2.00-3.00V.  Everything else passed. 

A couple of clicks later I had the location and I jacked the car up onto some jack stands. Once underneath the rear, I saw the sensor. Wiring was intact.

Then I saw the pivot arm that is attached to the sensor on one side and to a rear sway bar on other. The latter end was no longer connected. (See pics) I was able to zip tie it in place for now and see I was right.

broken link

Once rigged in place, I ran the tests in SDS again and the rear sensor passed with the correct voltage range.  I ran the pneumatic tests again, and all the corners leveled themselves. I took the car for a ride and it smooth and normal.  

rear level sensor w221

Woohoo!  Felt great to figure this one out.

This pic is of an intact rear sensor.  I put a curve on where it looks like mine broke off.  I have since swapped in a new one.

mb rear leel sensor suspention

 

2006-2013 (W221)